新版本Apache HTTP Server 2.4.51发布更新(有安全漏洞建议升级)

今天中午的时候看到群里网友在讨论新版本的Apache HTTP Server 2.4.51发布且建议更新升级,如果有服务器在使用较早版本的话可能需要升级安全,这次的版本中涉及到安全漏洞的问题。Apache HTTP 中2.4.50的修复补丁CVE-2021-41773 修复不完整,导致新的漏洞CVE-2021-42013。攻击者可以使用由类似别名的指令配置将URL映射到目录外的文件的遍历攻击。

16342453601.png插图

这里可以导致目录之外的文件越过默认的“require all denied”的配置,导致可以遍历请求这些文件。如果这些别名启用了CGI 脚本路径,则导致可以进行远程代码执行。

影响版本:

该漏洞影响 Apache 2.4.49 和 Apache 2.4.50,如果是早期的版本是不受影响的。所以,我们有些时候不升级也安全,当然最好还是保持最新版本。

修复问题:

Apache HTTP Server 2.4.51 已发布,2.4.51 主要是修复了在 2.4.50 中发现的安全问题,因此主要的变动是在 2.4.50 中,包括修复安全问题和部分 bug,以及增强功能。

1、mod_rewrite: 修复 [P] 规则的 UDS (“unix:”) scheme

2、event mpm: 如果子进程由于 MaxConnectionsPerChild 停掉,可正确地计算父进程中的活动子进程

3、mod_http2: 当一个服务器被优雅地重新启动时,任何空闲的 h2 worker 线程都会被立即关闭。另外,针对 OpenSSL 3.0 中的弃用情况,改变了 OpenSSL API 的使用方式,增加了所有其他的。

4、mod_dav: 正确处理由 dav providers 在 REPORT 请求中返回的错误

5、core: 不在二级连接上安装核心输入/输出过滤器

6、core: 添加 ap_pre_connection() 作为 ap_run_pre_connection() 的封装器,用它来防止运行 pre_connection 钩子的失败导致事后崩溃

7、mod_speling: 添加 CheckBasenameMatch PR 44221

如果我们需要升级的话注意数据备份。

未经允许不得转载:CDN-服务器-VPS优惠/促销/测评-撸主机评测 » 新版本Apache HTTP Server 2.4.51发布更新(有安全漏洞建议升级)
分享到: 更多 (0)

本站不对信息的真伪做任何的保障,请自行甄别,自负责任。

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址